New Features in Excel 2010/2013

Contents

Introduction .................................................................................................................. 2
1. Flash Fill............................................................................................................... 2
2. Quick Analysis ..................................................................................................... 4
3. Recommended Charts Command......................................................................... 5
4. Recommended PivotTables Command ............................................................... 5
5. Charts Option Buttons........................................................................................ 5
6. Formatting Data Labels in Charts ...................................................................... 7
7. Animations in Charts.......................................................................................... 7
8. Create a PivotTable Timeline to Filter Dates.................................................. 7
9. Using Slicers to Filter Data in PivotTables....................................................... 8
10. Using Slicers to Filter Data in a Table............................................................ 9
11. Sparklines For Analysing Trends ..................................................................... 10
12. Power View....................................................................................................... 11
13. Improved Help.................................................................................................. 11
14. Options on Opening Excel.................................................................................. 12
15. Improved Templates List.................................................................................... 12
16. File tab on Ribbon - opens Backstage View................................................... 12
17. Pinning Files to Top of Recent Documents List............................................... 13
18. Pinning Folders in the Save As area of Backstage view.................................... 14
19. Customize the Ribbon....................................................................................... 14
20. Change Display of Ribbon .............................................................................. 15
21. Paste Preview when Pasting............................................................................. 15
22. More Information in the Undo list................................................................... 15
23. Print and Print Preview together..................................................................... 16
24. Customize Office Background and Theme.................................................... 16
Introduction

This guide highlights many of the new features of Excel 2013 (some of these features were introduced for Excel 2010). The new features specific to Excel are listed first. The remaining features (from item no 13) are shared with other Office 2013 applications.

1. Flash Fill

Excel is able to recognize patterns of text. It can predict and prompt text to fill into cells. Sometimes just typing a second entry will begin the prompt, at other times use CTRL+E to initiate the Flash Fill.

E.g. Filling in a full name column if you have first name and surname columns

1. Begin a third column and type in the full name for the first record.
2. After beginning to type in the full name for the second record Excel will recognise the pattern and suggest text to fill into the remaining cells.

Alternative 1,
Type the first full name, then CTRL+ENTER, then CTRL+E

Alternative 2,
Type the first full name, AutoFill the list down in the usual way,
Then click on the Options button at the bottom of the list and select Flash Fill

Other examples summarized by the following figures:
In this example, type J in first cell
Then CTRL+ENTER, then CTRL+E

In this example, type J H in first cell
Then CTRL+ENTER, CTRL+E

Extract year

In this example type in the first cell,
Then CTRL+ENTER, CTRL+E
2. **Quick Analysis**

This is a new tool which instantly brings together many data analysis options which you can carry out on your selected data. For example, you can instantly create charts, pivot tables, sparklines, mini graphs, apply conditional formatting etc.

To use this feature:

1. Select some data,
2. Click on the **Quick Analysis** icon which appears bottom right. (or press CTRL+Q)
3. Go through all the different tabs to view all the possible options or to get quick ideas of ways to analyse the results.
4. Hover over an option on a tab and Excel will display a Live Preview.

---

### Live Preview of the Colour Scale option

![Live Preview of the Colour Scale](image)

---

### Quick Analysis tabs and their commands

![Quick Analysis tabs](image)
3. Recommended Charts Command

Recommended Charts is a new command appearing in Excel's Insert tab. It gets Excel to recommend the most suitable charts for your data, provides you with a preview of each of these charts based on your data and then allows you to select the one you prefer.

1. Select the data
2. From the Insert tab select **Recommended Chart**
3. Make sure the Recommended Charts tab is selected in the Insert Chart dialogue which appears.
4. Click on the various charts suggested on the left and view the preview on the right.
5. When you are ready click OK

4. Recommended PivotTables Command

This works in a similar way to Recommended Charts. The Recommended PivotTables command button is available from the Insert tab, and you are offered various suggested PivotTables which you can preview and select from.

5. Charts Option Buttons

When a chart is selected three chart option buttons appear on the top right of the chart.

- **Chart Elements**
  Add, remove or change chart elements such as title, legend, gridlines and data labels

- **Chart Styles**
  Select a style and colour scheme

- **Chart Filters**
  Edit what data points and names are visible on your chart
NOTE:
Only two contextual tabs are available on the ribbon when you select a chart (Design and Format) instead of three as in previous versions of Excel, i.e. the Layout tab is missing. The many options and commands from the old Layout tab are replaced by the new Chart Options buttons described above. You may need to click on various sub options to get to the formatting option you require.

Example of options within the Chart Elements options button

Example of more options for Data Labels

TIP:
Select just one series in the chart. Then select the Chart Elements button, the Data Labels checkbox, and then click on arrow at end to see options of types of data labels.

If you require more options click on the More Options command. This will bring up a pane of the right with many more options. Click on relevant icon for which of the four types of formatting you wish to carry out. i.e. Fill and Line, Effects, Size and Properties or Label Options.

Make your selections from the options offered.
6. Formatting Data Labels in Charts

You can format all the various elements of a chart in many ways, too numerous to list everything in this guide. Data labels have been selected for an example to show in more detail in this guide.

To display data labels:
Click on the chart, select one of the series, click on the first Chart Option button which is Chart Elements. For our example select to have the data label on the Outside End. (see more details given on previous page)

To format the data labels:
- To have the data label connect to the data point via a leader line simply click and drag the data label to a new position.
- To change the data label shape, right click the data label, select Change Data Label Shape, and select the shape you require.
- To change the data label shape fill, right click the data label, select Format Data Label, and then select your options from the Format Data Labels task pane which appears on the right of the screen.

7. Animations in Charts

When you edit any source data for a chart the chart will change through an animation. This draws your attention to where the changes have been made and can make things clearer.

8. Create a PivotTable Timeline to Filter Dates

An easier method is now available to allow you to filter PivotTable data by date and this is by means of a timeline box. Once added you can very easily and quickly select the period you wish to analyse.

1. Insert a pivot table in the normal way,
2. If required, add your Date, Order Date, Date of Birth or similar field into the pivot table. Note, the timeline box will work even if the Date field is absent from the PivotTable
3. Go to the Analyse contextual tab on the ribbon and select the Insert Timeline command.
4. In the Insert Timelines dialogue box check the box for the field name you require and click OK
5. Select the months you require from the timeline box and the pivot table will be filtered accordingly.

6. Using Slicers to Filter Data in PivotTables

Slicers allow you to filter PivotTables data in an interactive way. The Slicers provide buttons which allow you to carry out quick filtering. The buttons remain in view and clearly indicate the filtering status. This makes it very easy to understand what is being shown in the current data display.

1. Insert a pivot table in the normal way,
2. Add the required fields to the pivot table.
3. Go to the Analyse contextual tab on the ribbon and select the Insert Slicer command.
4. In the Insert Slicers dialogue box check the boxes for the field names you require and click OK
   
   TIP: You can select a field even if it has not been selected to be displayed in the pivot table.
5. Click on the appropriate slicer buttons to filter for what is required

TIPS:
- You can select the timeline box to show quarters, years or days instead.
- Click on the Clear filter button (top right) to clear the filter and bring all the data back.
A filtered PivotTable with 6 slicers underneath showing filtering choices

NOTES:
- Slicers can be moved and resized and also overlapped.
- You can select multiple buttons in a slicer using SHIFT+CLICK or CTRL+CLICK

10. Using Slicers to Filter Data in a Table

Slicers work in the same way for an Excel table as they do for PivotTables. Just remember to convert your data to a table before you start.

1. To convert your data to a table, select your data, go to Insert tab, select Table and click OK
2. Go to the Design contextual tab on the ribbon and select the Insert Slicer command.
3. In the Insert Slicers dialogue box check the box for the field names you require and click OK
4. Click on the buttons to filter for what is required
11. Sparklines For Analysing Trends

Sparklines are tiny charts inside a single worksheet cell. They are used to visually represent and show a trend in the data. This is useful if you are sharing your data with other people and you wished to draw attention to particular trends, high or low points without having to insert a full chart.

To create a Sparkline:

1. Select data in a table
2. Go to the Insert tab and select the type of Sparkline you require
3. In the Create Sparkline dialogue box which appears enter the Location range, i.e. the reference for the cell you wish the Sparkline to display in, (or click on the spreadsheet to indicate this)
4. Click OK.
To format the Sparkline:

1. Select the cell which has the Sparkline and click on the **Design** contextual tab on the ribbon.
2. Select the commands and options you require.

![Sparkline Style and Color](image)

- Highlight certain points on the Sparkline e.g. Highest, Lowest
- Sparkline style
- Sparkline colour

### 12. Power View

Power View is an interactive data exploration, visualization, and presentation experience. An example of what can be achieved is given opposite:

A full description and instruction are out of the scope of this guide. Use the Help feature in Excel to learn more about this feature.

![Power View Example](image)

### 13. Improved Help

As in previous versions of Excel 2013, clicking on the question mark button in the top right corner of the screen will open the Excel Help dialogue box which allows you to search for help by topic by typing in keyword(s).

In addition to the usual keyword search more options are offered to you such as a list of the most popular help searches, shortcut links to what’s new, keyboard shortcuts, tips for tables and basic training files.

![Excel Help Dialogue Box](image)
14. Options on Opening Excel
When you open Excel you are no longer taken to a blank spreadsheet but to a range of options. You can select to open a recently opened spreadsheet, a blank spreadsheet, a template or navigate to other existing files.

15. Improved Templates List
Many more templates are available and you can easily search for more template from thousands available online. To get to the template click on the File tab, then select New.

You can:
- Select one of the templates by clicking one of the thumbnail
- Type a keyword in the search box at the top of the screen to look for more templates online.
- Use the horizontal links such as Budget, Invoice, List.

16. File tab on Ribbon - opens Backstage View
The File tab replaces the old Office button. Once clicked it provides you the usual list of commands relating to the control of files (e.g. New, Open, Save, Save As, Print, Close), a list of file properties and easy access to further commands and features such as compatibility, protection and versioning. This new arrangement is referred to as the Backstage view.

To open the backstage view click the File tab.
Click the **Back** button to return to the spreadsheet

**TIP: Shortcuts**
- CTRL+O opens backstage view and goes straight to the Open command and other options, (i.e. shows a list of recent files you can open)
- CTRL+F12 opens the Open dialogue box so you can immediately navigate to the file you wish to open

**17. Pinning Files to Top of Recent Documents List**

When you click on the **File** tab, then select **Open**, (or CTRL+O) you see a list of recently opened files.

You can pin any of these files to the list to in effect create a shortcut to them.

To do this hover over the file name, move your mouse over the pin on the far right side and click. All pinned files remain at the top of the list. To unpin, click on the pin again.
18. Pinning Folders in the Save As area of Backstage view

When you click on the File tab, then select Save As you see a list of recently saved to folders.

You can pin any of the folders to the list to in effect create a shortcut to them.

To do this hover over the folder name, move your mouse over the pin on the far right side and click.

19. Customize the Ribbon

You can create your own ribbon tabs, groups within the tabs and then assign whichever commands you desire.

To do this click on the File tab, click on Options (final command on blue bar on left), then select the Customize Ribbon option on the left

Use the:
- New Tab,
- New Group,
- Rename buttons to set up your tab and groups, then the Add button to bring across commands.

Example of new tab with commands
20. Change Display of Ribbon

To the left to the Minimize button is the Ribbon Display Option button.

It gives you the option to just display: the tabs, both the tabs and ribbon, or go into auto-hide mode.

21. Paste Preview when Pasting

Whenever you paste text and other elements into your spreadsheet a drop down menu appears with one or more Paste Options. Hover over each of the paste options and watch the Paste Preview change, i.e. you can see what each option will do to your pasted text before you click on the option to select it.

The Paste options include: Paste, Values, Formula, Transpose, Paste Link, Values and number formatting, Values and source formatting

22. More Information in the Undo list

When you click on the down arrow after the Undo button in Excel 2013 not only do you see a list of the actions you performed but you see the text you typed (or at least the beginning few words of your typing). This makes it easier to decide how far you should undo or which typed text you should undo.
23. Print and Print Preview together

The print dialogue box has now been replaced by a Backstage view window. To open it click on the File tab, then Print. Alternatively use the shortcut keys: CTRL+P.

All the usual print commands are there but it may take a while to get used to the new layout.

A preview of the file is offered on the right side of the screen.

24. Customize Office Background and Theme

If you feel there is too much white background you can customize your Office applications to have an alternative theme. As a result some parts of the application window will no longer be white.

To do this click on File and select Account. Then select the Office Theme colour. You may also wish to select an Office Background.

NOTE: A change made in one Office application will be reflected in all the others.