Excel 2013 as a Database

Contents

Introduction .................................................................................................................. 2
  Guidelines for Preparing Data to be Used as a Database ........................................ 2
  Excel Format as Table Feature .................................................................................. 2
Defining a Range as a Table ....................................................................................... 3
  Defining a Range through the Home Tab ................................................................ 3
  Defining a Range through the Insert Tab ................................................................ 3
The Tables Tools Design Contextual Tab ................................................................... 4
  Convert a Table Back to a Range of Data ................................................................. 4
The Table Name .......................................................................................................... 5
Features of a Table .................................................................................................... 5
  Working with the Total Row ..................................................................................... 6
  Inserting and Deleting Rows and Columns ............................................................... 6
Sorting .......................................................................................................................... 7
  Simple Sorts ............................................................................................................. 8
  Multiple Sorts ......................................................................................................... 9
  Sorting by Colour .................................................................................................... 10
Filtering with AutoFilters ........................................................................................ 11
  Displaying the AutoFilter arrows ........................................................................... 11
  AutoFiltering .......................................................................................................... 11
  Multiple AutoFiltering ........................................................................................... 12
  Removing AutoFilters ............................................................................................. 12
Further Filtering Options ......................................................................................... 13
  Filtering by Colour ................................................................................................ 15
  Filtering for Blanks ................................................................................................. 16
Subtotals ..................................................................................................................... 16
  Inserting Subtotals ................................................................................................. 16
  Removing Subtotals ............................................................................................... 18
Slicers .......................................................................................................................... 19
Introduction

Excel is often used as a database when simple management of data and analysis is required. As Excel database features are easy and quick to learn you can get up and running with databases very quickly.

The term ‘list’ as used in Excel refers to a series of worksheet rows that contain related data, such as a set of contact names and phone numbers. A list can be used as a database, in which rows are records and columns are fields. The first row of the list has labels for the columns referred to as the field heading.

Guidelines for Preparing Data to be Used as a Database

- When you have small amounts of data
- There is little or no duplication of data. For example you have don’t have to enter the same address several times in lots of different records.
- The data is only going to be used for simple reporting, eg. Mail-merging data with Word, simple calculations, filtering or looking up information.

Excel Format as Table Feature

When you use Excel 2013 to manage data as a database you are advised to use the Format as Table feature (where you designate a range of cells to be in a table.) This will enable you to manage and analyze the data more efficiently and independently of the data outside of the data range. It is still possible to work with databases without using this feature and notes are provided in this guide for working in both conditions.
Defining a Range as a Table

There are two methods for defining a range as a table. Defining a range means converting selected data into a table.

**Defining a Range through the Home Tab**
1. Click anywhere inside the data (or select the range of cells you wish to be in the table)
2. Go to the Home tab, locate the Styles group and click on the Format as Table command button
3. Select a style from the Table Style gallery which appears
4. In the Format as a Table dialogue box check the range has been correctly selected
5. Make sure that the My table has headers checkbox is ticked. (If it is not then Excel will number each of your columns using “Column1”, “Column2” etc.
6. Click OK

**Defining a Range through the Insert Tab**
1. Click anywhere inside the data (or select the range of cells you wish to be in the table)
2. Go to the Insert tab, locate the Tables group and click on the Table command button
   Alternatively, press CTRL+L shortcut keys
3. In the Create Table dialogue box check the range has been correctly selected
4. Make sure that the My table has headers checkbox is ticked. (If it is not then Excel will number each of your columns using “Column1”, “Column2” etc.
5. Click OK

Regardless of which method above you used you will now have converted your range to a table and you will see that the Tables Tools Design contextual tab is available on the ribbon. Even though you did not get the chance to select a table style in the second method a default table style will be applied.
An excel table

Notice the AutoFilter arrow, one located at each field heading

The Tables Tools Design Contextual Tab

Use the command buttons on the **Design** tab to customize or edit the table. For example:

- Select an alternative table style from the table styles gallery. If you do not want any formatting on your table select the table style **None**.
- Select which formatting attributes you require for your selected table style.

To do this add/remove ticks from the 6 checkboxes in the **Table Style Options** group

**Convert a Table Back to a Range of Data**

This is the opposite of defining a range as a table. This may be necessary for some Excel features, for example, when you wish to use Subtotals.

1. Click anywhere in the table
2. Click on the **Tables Tool Design** contextual tab to make it active
3. Locate the **Tool** group and click on the **Convert to Range** command button

Or,

1. Right click the table, select **Table** and then **Convert to Range**.

**NOTE:**

In some cases when you convert to range you may find that the table formatting has been left in place. To remove the formatting select the whole range of cells and apply Normal style to the cells (Home tab, Styles group, Cell styles command)
The Table Name

Every table you create is given a name by Excel. For example, Table1, Table2, Table3. You can rename the table to something more meaningful. One really useful facility which a table name provides you with is the ability to navigate to that table very quickly from anywhere in the worksheet or workbook.

To Rename a Table:
1. Click in the table and then on the Design contextual tab
2. Locate the Properties group
3. Click in the Table Name box and type a new name.
   (Note, you must not use any spaces in the name.)
4. Press Enter on the keyboard

To Navigate to a Named Table:
1. Click on the down arrow at the end of the Name Box
2. Click on the name you require from the drop down list which appears

Features of a Table

The following features are immediately visible when you define a range as a table:

- Formatting to the Table Cells. This is applied whether you selected a table style or not. If you did not select a table style a default table style is applied. The advantage of table formatting is that it makes it easier for you to locate a table and see the whole range associated with the table.

- AutoFilter arrows. Each field (column) heading has an AutoFilter arrow

- One resize handle. A resize handle in the bottom right corner allows you to click and drag to include further data into the table or to exclude data from the table.

TIP:
It is possible to have more than one list on a worksheet. The table formatting helps you distinguish one list from another.

You can delete and add rows in one list independently without affecting any other. This would be more difficult without defining tables.
**Working with the Total Row**

The Total Row is very useful as it allows you quick access to functions and the ability to carry out calculation on contents of columns. It can be switched on or off as required.

**To Switch On/Off the Total Row**

1. Click in the table and then on the **Design** contextual tab
2. Locate the **Table Style Options** group
3. Put a tick in the **Total Row** checkbox

This displays the Total Row at the end of the table and the final column will be summed.

**Note:** If the last column contains data that cannot be summed, such as text, Excel will count the number of items instead of summing values.

**To Apply Calculations to Other Columns**

It is possible to carry out calculations other than sum and to carry them out on columns other than the final column.

1. Click in the total row at the bottom of the column you wish to carry out the calculation for
2. Click on the arrow which appears on the right of the cell
3. Select the function you require from the drop down menu

**To Change a Calculation for a Column**

1. Click in the cell which has the calculation you wish to change
2. Click on the arrow which appears on the right of the cell.
3. Select the function you require from the drop down menu.

**Inserting and Deleting Rows and Columns**

**To Insert a Row/Column At the End of a Table by Typing**

Simply click in the next available row or at the top of an adjacent column and begin typing. Excel will automatically expand the table to include that row or column. Note, you will need to switch off the Total row to insert a new row successfully.
TO INSERT OR DELETE A ROW OR COLUMN ANYWHERE IN THE TABLE USING RIGHT CLICK

1. Right-click the appropriate cell. The cell you right click must be:
   - below where you want to insert a new row, or
   - to the right of where you want to insert a new column

2. Select **Insert** or **Delete** form the shortcut menu

3. Select your choice from the options offered.

   See opposite:

   ![Insert and Delete options](image)

ADDING ROWS AND COLUMNS BY DRAGGING THE RESIZE HANDLE

Click the resize handle in the lower right corner and drag down (or across) to the required position.

You now have new rows (or columns) to type into.

NOTES:
- If the added cells had data in them then the data will be included in the table.
- The tables’ formatting will be extended.
- You cannot insert rows and columns in the same click and drag. First you must click and drag in one direction and then in the other.

REMOVING ROWS AND COLUMNS BY DRAGGING

Click the resize handle in the lower right corner and drag up (or across to left) to eliminate the data you do not wish to be included in your table. The data will not be deleted but just removed from the table and any functions you carry out on it, such as sorting, filtering.

NOTE:
- You cannot delete rows and columns in one click and drag. First you must click and drag in one direction and then in the other.

![Sorting example](image)

Sorting

When working with a large table or database, it is useful to have it organized into a particular order. For example, if you have a database where the records are for different people you may wish to organized the records alphabetically by surname.
It would be time-consuming and impractical when adding items to a table to have to find the correct place in the table and make a space for them before being able to type them in. It is far better to enter the details at the end of the table and then sort the whole table when you have completed your typing. Sorting also has to be carried out before using other useful Excel tools such as sub-totals.

It is possible to sort data which has not been formatted as a table. Each method below states whether it can be used on data not formatted as a table.

**Simple Sorts**

**Sorting Using Right Click**
This method can be used with data whether it has been formatted as a table or not.
1. Right click any cell in the column you wish to sort
2. Select Sort and then either Sort A to Z or Sort Z to A

**Sorting Through the Home Tab**
This method can be used with data whether it has been formatted as a table or not.
1. Click in any cell in the column by which you wish to sort
2. Go to the Home tab and locate the Editing group
3. Click on the Sort and Filter command button
4. Click either the Sort A to Z or Sort Z to A option on the drop down menu

**Sorting Through the Data Tab**
This method can be used with data whether it has been formatted as a table or not.
1. Click in any cell in the column by which you wish to sort
2. Go to the Data tab and locate the Sort & Filter group
3. Click either the Sort A to Z or Sort Z to A command buttons

**Sorting Using the AutoFilter Arrows**
This method can be used with data only if the field headings have AutoFilter arrows. Although these arrows are a feature of Tables it is possible to switch on AutoFilter arrows without having to define a range as a table. (see page 11 for more details)
1. Click on the AutoFilter arrow for the column by which you wish to sort
2. Click either the Sort A to Z or Sort Z to A option on the drop down menu
Multiple Sorts

Using a Series of Simple Sorts
It is possible to carry out multiple sorts to a table or database by carrying out series of simple sorts described above but you must use the reverse of the final order that you want to see. For example, if you wish to have your table display by surname first and then surname (like a telephone directory) you will have to carry out the sort by first name first, and then surname. Excel remembers the order of each previous sort.

Using the Sort Dialogue Box
You may find the method above of carrying out sorts in reverse order too confusing and will find that you prefer going through the Sort dialogue box. You can use this method whether the data has been formatted as a table or not.

1. Click in any cell within the table or database
2. To display the Sort dialogue box either:
   • Go to the Home tab, locate the Editing group, click on the Sort & Filter button and select Custom Sort, or,
   • Go to the Data tab, locate the Sort & Filter group and click on the Sort command button
3. In the Sort dialogue box which is displayed specify the columns and sort orders you require
4. Click OK

Sort dialogue box with 3 levels specified

Notes:
• The Sort dialogue box starts off with one level. For every extra level you wish to add click on the Add Level button.
• To change the level priorities or orders, click on the level you wish to change and use the Move Up or Move Down button to reposition to correct order.
• It is possible to specify sorts for up to 64 levels.
Sorting by Colour

It is possible to sort a column by colour whether the data is in a table or not. You may have highlighted certain surnames with a colour using Fill or Font colour formatting. Then you decide to sort by colour.

Using the Sort Dialogue Box

1. Apply Fill or Font colour to specific cells. You may wish to apply the formatting to cells only in one column or apply the formatting to all the cells relating to each record you wish to highlight
2. Click in any cell within the table or database
3. To display the Sort dialogue box either:
   - Go to the Home tab, locate the Editing group, click on the Sort & Filter button and select Custom Sort, or,
   - Go to the Data tab, locate the Sort & Filter group and click on the Sort command button, or
   - Click on one of the AutoFilter arrows, select Sort by colour, and then Custom Sort
4. In the Sort dialogue box specify which column you wish to sort by.
   (If you coloured all the cells for each record it will not matter which column you select.
5. From the Sort On box select Cell Colour or Font Colour depending upon which formatting you used.
6. From the Order box select the colour you wish to sort and what position.

**NOTE:**
If you have applied more than one cell/font colour to records in your database you may wish to sort by all the colours.

For every extra colour you wish to sort by add an extra level to the sort by pressing the Add Level button, (located at the top of the Sort dialogue box), and fill in the necessary details.
7. Click OK
**USING THE AUTOFILTER ARROWS**

This method can be quicker than using the Sort dialogue box described above.

1. Click on the AutoFilter arrow for the column which has colour applied to the cells,
2. Select **Filter by Color** option,
3. Select the colour you wish to sort by.
4. If you wish to sort by more than one colour repeat steps 2 & 3 for each further colour.

**Filtering with AutoFilters**

Sometimes when using a table/database it isn’t enough to have the items organized into a particular order, there may be a requirement to look at a number of items that can’t be grouped together by a sort. In such cases filters should be used.

Filters allow the temporary hiding of items that do not meet specified criteria. This is useful if you wish to print only specific records.

**Displaying the AutoFilter arrows**

You can only AutoFilter when the AutoFilter arrows are present to the right of each field (column) heading. They can be switched on by the following methods:

- Defining a range as a table (see two methods described on page 3)
- Selecting the **Filter** command from the Data tab, Sort & Filter group.
- Selecting the **Sort & Filter** command (Home Tab, Editing group) and clicking on **Filter**

**AutoFiltering**

1. Click on the AutoFilter arrow for the column which contains the data you wish to filter by. This will show a list of all values available for that column, plus further options as detailed on the pages 13-16.
2. Make sure there are ticks present for only the checkbox items you require. For example, **England** and **Wales**
3. Click OK.

**TIP:**
Unticking **Select All** will untick all the checkboxes in one go allowing you to quickly select just one or two items.
Example,
If you tick only the checkboxes for England and Wales, Excel will display only records where England or Wales is the entry in the Country column. See opposite.

NOTE: The AutoFilter arrow for the Country column changes appearance in order to indicate that the table is being filter according to that column.

Multiple AutoFiltering
It is possible to carry out successive filtering to narrow your results further.

Example,
You may wish to first filter all those living in England and then those with a surname Cahill. See opposite.

NOTE: The order that filters are applied is important when carrying out multiple filtering. Once a record is hidden by one filter it will not reappear in subsequent filters until the filter that hid it is removed i.e. when applying a second or third filter to a table, the only values available for each subsequent filter are the values that are still visible after the previous filter.

Removing AutoFilters
Either:
- Click on each relevant AutoFilter arrow and select Clear Filter From “field name”

Or,
- Go to the Data tab, locate the Sort & Filter group, click on the Clear command button

Or,
- Go to the Home tab, locate the Editing group, click on the Sort & Filter command button, and then on Clear
Further Filtering Options

Further filtering options are available from the AutoFilter arrow drop down menu. Which options are open to you depends upon whether the column you are filtering has text, number or date entries. The three diagrams below show the different menu options available for Text, Number and Date Filters:

*When column has text entries*

*When column has number entries*

*When column has date entries*
When you select any of these options a Custom AutoFilter dialogue box will appear with some of the required settings already selected. You will need to enter a number or text and then click OK.

Some examples of text, number and date filter options are shown below:

**TEXT FILTER EXAMPLE**: **CONTAINS**

*Contains* is already selected in the dialogue box. You need to type in the word you are filtering for on the right, for example, *travel* for the Hobbies column. See opposite.

Results of the filter are shown below. Any record where *travel* is present in the **hobbies** field is filtered.

**NUMBER FILTER EXAMPLE**: **BETWEEN**

The dialogue box is already set up so you only need to type in the two values you wish to select between. For example, you wish to select all those who scored between 50 and 75 in their Exam for Yr1. See opposite.

Results of the filter are shown below.
**NUMBER FILTER EXAMPLE : TOP 10**

From the dialogue box you can select *Bottom* instead of *Top*, and select how many instead of 10. The default setting for what to look for is *Items*. You can select *Percentage* instead.

Results of two filters are shown opposite:

<table>
<thead>
<tr>
<th>Items</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exam Yr 1</td>
</tr>
<tr>
<td>Exam Yr 1</td>
</tr>
<tr>
<td>Exam Yr 1</td>
</tr>
<tr>
<td>Exam Yr 1</td>
</tr>
<tr>
<td>Exam Yr 1</td>
</tr>
</tbody>
</table>

**DATE FILTER EXAMPLE : BETWEEN**

Filter for everyone born in the 50’s based on Date of Birth column.

In the dialogue box enter the first and last dates for the period you require. See opposite.

Results of filter are shown opposite:

<table>
<thead>
<tr>
<th>Date of Birth</th>
</tr>
</thead>
<tbody>
<tr>
<td>09/06/1953</td>
</tr>
<tr>
<td>01/02/1953</td>
</tr>
<tr>
<td>10/10/1957</td>
</tr>
</tbody>
</table>

**Filtering by Colour**

If any data in the column you are filtering by has been formatted with colour, (either Fill or Font Colour), the option to *Filter by Colour* will be available in the AutoFilter drop down menu.

In the example opposite you can see that both cell colour and font colour formatting has been applied to various records:

If you click on an AutoFill arrow, then the *Filter by Colour* option, you will be presented with options relating to the formatting you have used. In the example opposite there are five options.

If the Cell Colour Orange is selected the result will be as shown below
Filtering for Blanks

If a column you are filtering has blank entries there will be a further option in the AutoFilter drop down menu: Blanks. You may need to scroll down to see this option at the bottom of the menu options list.

Subtotals

In a long table, subtotals can be used to automatically summarize and collate information on a worksheet. A great advantage is that they can be added and removed from a table without affecting the original data.

NOTE

- **The Subtotals function will not be available to you** if you have used the Format as Table option on your data (see first method on page 3). You will first need to convert the table back to a range. (see page 4)

- **The Subtotals function will be available to you** If you have defined a range through the Insert tab (see second method on page 3). You will not need to convert back to range.

Inserting Subtotals

1. If necessary covert a formatted table back to a range of data. You will know if this is necessary if the Subtotals command (Data tab, Outline group) is greyed out.
2. Sort the table by the column for which you want to calculate subtotals. For example, to summarize the number of people living in each “Country” in a list of names and addresses sort the table by the “Country” column.
3. Click a cell in the table.
4. Go to the Data tab, location the Outline group and click on the Subtotals command button.
5. In the **At each change** field, select the column which contains the groups for which you want subtotals. This should be the same column by which you sorted your table in step 2 above. (In this case “Country”)

6. In the **Use function** box, click the function you want to use to calculate the subtotals. (Use sum to add up numbers, and Count when you just want to count items)

7. In the **Add subtotal to** box, select the check box for the columns which contain the values for which you want subtotals.

This subtotal result below show the number of people from each country.

E.g. click on Level 2 button and Excel will display only the country count results and grand total.
To hide / show details for individual subtotals, (for countries) either:

- Click on the relevant + or - symbols to the far left of the subtotal
- Click on the Show Detail or Hide Detail command buttons (Data tab, Outline group)

**Removing Subtotals**

1. Click a cell in the table
2. From the Data menu select Subtotals
3. Click on the Remove All button

**Example of Subtotals Involving the Sum Function**

If you wish to get subtotals showing how much money has been paid up for each field trip:

<table>
<thead>
<tr>
<th>Entries in dialogue box</th>
<th>Subtotal results</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Subtotal</strong> dialog box</td>
<td><strong>field trip</strong></td>
</tr>
<tr>
<td>At each change in:</td>
<td>Lakes</td>
</tr>
<tr>
<td>field trip</td>
<td>Lakes</td>
</tr>
<tr>
<td>Use function:</td>
<td>Lakes</td>
</tr>
<tr>
<td>Sum</td>
<td>Lakes</td>
</tr>
<tr>
<td>Add subtotal to:</td>
<td>Lakes</td>
</tr>
<tr>
<td>Town/City</td>
<td>Lakes</td>
</tr>
<tr>
<td>Country</td>
<td>Lakes</td>
</tr>
<tr>
<td>Postcode</td>
<td>Lakes</td>
</tr>
<tr>
<td>Date of Birth</td>
<td>Lakes</td>
</tr>
<tr>
<td>field trip</td>
<td>Lakes</td>
</tr>
<tr>
<td><strong>field trip payments</strong></td>
<td><strong>Lakes Total</strong></td>
</tr>
<tr>
<td></td>
<td>Peaks</td>
</tr>
<tr>
<td></td>
<td>Peaks</td>
</tr>
<tr>
<td></td>
<td>Peaks</td>
</tr>
<tr>
<td></td>
<td>Peaks</td>
</tr>
<tr>
<td></td>
<td>Peaks</td>
</tr>
<tr>
<td></td>
<td>Peaks</td>
</tr>
<tr>
<td></td>
<td><strong>Peaks Total</strong></td>
</tr>
<tr>
<td></td>
<td>wales</td>
</tr>
<tr>
<td></td>
<td>wales</td>
</tr>
<tr>
<td></td>
<td>wales</td>
</tr>
<tr>
<td></td>
<td>wales</td>
</tr>
<tr>
<td></td>
<td>wales</td>
</tr>
<tr>
<td></td>
<td><strong>wales Total</strong></td>
</tr>
<tr>
<td></td>
<td>Grand Total</td>
</tr>
</tbody>
</table>
Slicers

Slicers allow you to filter data in a table in an interactive way. The Slicers provide buttons which allow you to carry out quick filtering. The buttons remain in view and clearly indicate the filtering status. This makes it very easy to understand what is being shown in the current data display.

Just remember to begin by converting your data to a table before you start.

1. To convert your data to a table, select your data, go to Insert tab, select Table and click OK.
2. Go to the Design contextual tab on the ribbon and select the Insert Slicer command.
3. In the Insert Slicers dialogue box check the box for the field names you require and click OK.
4. Click on the buttons to filter for what is required.

A filtered table with 7 slicers underneath showing filtering.