Skip to site navigation

Technical Pre-Requisites

ISD develops and deploys a number of Administrative Applications. Increasingly, these applications are accessed via a web browser. Given the range of web browsers in operation at UCL, ISD cannot test comprehensively on all browsers and platforms. Although most recent browsers should work, our systems are tested on the following:

  • Staff WTS 2000 service running Internet Explorer 6 and Firefox 3
  • Staff WTS 2010 service running Internet Explorer 8 and Firefox 4
  • ADS Service running Internet Explorer 8 and Firefox 11
  • Windows Browsers: Internet Explorer 6-9, Firefox 3 and above.

Many of our web accessible systems require Java.

Internet Explorer 6: Some newer web-based applications do not perform well on older browsers, especially Internet Explorer 6 - we recommend using Firefox or a later version of Internet Explorer. For users of Staff WTS 2000, Firefox is recommended.

Applications known to have performance or display problems with IE6:

More details about Java are available:

Note: Some browsers will disable earlier versions of Java if they have know security risks (usually versions below Java 6 update 29). It is possible to re-enable the Add-on by selecting the Add-ons menu option, finding the Java plug-in and selecting Enable. This action may be required if you are using WTS but is not recommended for your own desktop computers (instead, upgrade to Java 6 Update 33 or higher using the link above).

hr

Notes on Browser Support and Compatibility - Java:

  Operating System Browser Notes
green light Windows XP
Internet Explorer 6 to 8
Java applications run and have been fully tested
green light Windows XP
Firefox 3 and above
Java applications run and have been fully tested
red light Mac
All browsers
As of October 2012, Apple no longer provide browser plugins for their version of Java 6. Mac users should install Java 7 from the Java site and use this to access the Staff WTS service. UCL Admin Systems can be run from within WTS using either Internet Explorer or Firefox.
amber light Windows 7
Internet Explorer 9
Java applications have been partially tested - no issues have been found.*
Amber - warning Windows 7
Firefox 3 and above
Java applications have been partially tested - no issues have been found.*
Amber - warning Windows
Google Chrome
Java applications have been partially tested but should run with a standard Java installation.*
Amber - warning Linux
Firefox, Chrome
Java applications have not been tested but should run with a standard Java installation.*

* If problems are reported with this configuration, you may be asked to switch to an alternative browser or to use the Staff WTS service which has been fully tested.

 [IDINA-011]

Page last modified on 01 aug 14 12:09