Java for UCL Administrative Applications

Please read the Java installation instructions on the main ISD website before using these installation files.

Only use these files if directed by your application support team.

Notes:

  • Always check www.java.com for the latest versions of the Java Runtime Environment. Install from there where ever possible.
  • The installers listed below are for recent and older version of Java known to work with UCL Admin Systems. Use of older versions may make your system vulnerable to attack.
  • Always use the latest version of Java 8 unless otherwise directed.
  • Always make sure Java is set to auto-update (this can be checked via the Java Control Panel).
  • Always uninstall older versions of Java that are no longer required. The Java installer will usually check for older versions and help you uninstall them.

Java 8 Installer for Windows: Update 31

Java 8 Installer for Windows (64-bit): Update 31

Java 8 Installer for Mac (64-bit): Update 31

Java 7 Installer for Windows: Update 45

Java 7 Installer for Windows (64-bit): Update 45

Java 7 Installer for Windows: Update 17 [Use with FAMIS only if requested by Support staff]

Java 6 Installer for Windows: Update 45 [Use with caution!]

 

Quick Links